3d modeling assistance

Post Reply

Topic author
Terran Settler (Unemployed)
Terran Settler (Unemployed)
Posts: 1
Joined: Wed Oct 20, 2010 6:12 am

3d modeling assistance

Post by Circulation » Wed Oct 20, 2010 6:16 am

:) Greetings,

I am trying to make a custom wc3 model based off the Footman. But, he has proven unwilling. :frown:

I extracted the footman (along with textures) from the wc3 mpq using WC3 Viewer.

I am using 3dsMAX 2011 and the mdximportexport plug-in from sc2mapsters.com. This is where my trouble begins...

The plug-in allows me to import the model with full animations, but when I attempt to do so I receive an error that it exceeded the skin count. This does not appear to be problematic... what is problematic is that the bones and animations have been distorted somehow. Using the animation slider at the bottom of the screen I can browse through all the animations - and it isn't pretty, much like a troll dipped in boiling tar, speared by a dozen blades and writhing in pain. My guess is that the bone rotation has been somehow inverted or multiplied, because the entire model stretches and bends and falls apart at any given point along the animation sequence. The head rolls down to the chest, the tip of the sword moves way above the left shoulder...

Does anyone know why this is happening and if there is a fix? I would assume that the plug-in I am using was not meant to be used in 3dsMAX 2011. The website says it was designed for versions 2006 through 2010.

Is there a different importer plug-in for 2011 that would work for me? Alternatively, is there a program that converts .mdx directly into .max or .3ds? The importer for 3dsMAX appears to be able to handle other major 3D modeling formats as well (such as Lightwave's).

When I tried to import the .mdx into 3ds 2011 without animations and bones (i.e. simply as a mesh), I proceeded to edit the mesh and scrap animate a basic stand sequence, but when I attempted to export him I got an error: '-- Unable to convert: Undefined to type: Integer.'

Here is some background information: The model has all of the standard wc3 bones and ref's I know of, with proper wc3 naming conventions. I gave it the appropriate animation tags and notes (according to an animating tutorial). The model is divided into multiple meshes (one or team color, one of his cantine, one for the hilt of his sword when he sheathes it, and another for his corpse). None of them are hidden or frozen. There are about 814 polys (high for wc3 but I am considering him for sc2). I selected everything (meshes and bones) and hit the convert button. The error came up. I experimented with exporting individual meshes, one at a time. But unfortunately I got the same error.

Again, it seems the plug-in (or 3ds MAX) has failed me. Or am I doing something wrong? Any tips or ideas will be greatly appreciated.

Note: I can supply additional information upon request. I will be checking this thread frequently for responses and will update with anything I learn about.

Thanks (in advance)! :]

User avatar

Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8305
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘ జ్ఞ‌ా

Re: 3d modeling assistance

Post by IskatuMesk » Wed Oct 20, 2010 2:26 pm

No one here will be able to help you, you're best to ask NiN the guy who made the plugin himself on mapster (through a PM perhaps), unfortunately. And as he's really busy with uni work these days a timely response is also unlikely.

I am not sure if the plugin fully supports 2011 either. :\

Also, 800 polies is very small for wc3. :)

User avatar

Xel'naga Administrator
Xel'naga Administrator
Posts: 6530
Joined: Wed Aug 16, 2006 5:21 pm
Location: His Ashworld Planet

Re: 3d modeling assistance

Post by Lavarinth » Thu Oct 21, 2010 9:52 am

This may be possibly relevant to the fact you're using 2011 over 2006-2010, but I can't guarantee that statement.
- - Lavarinth
Campaign Creations Administrator

Post Reply