WoS Versions

Created by RazorclawX, Wanderers of Sorceria tells an epic length story through multiple chapters and books for WarCraft III.

Moderator: RazorclawX

Post Reply
Stalkslayer
Terran Academy Student (50k mineral debt)
Terran Academy Student (50k mineral debt)
Posts: 6
Joined: Thu Jan 30, 2020 8:23 am

WoS Versions

Post by Stalkslayer »

Maybe I'm just doubting your ability to make this work, but are you sure the latest release of WoS is compatible with 1.26-1.31 +reforged?
It appears to me, from the logic of the prior listed releases (1.26-1.28) that the correct compatibility of the lates release should be
1.28-1.31 +reforged.

Correct me if I'm wrong ^^'
Sorry if I was just annoying you and it is actually compatible with 1.26-1.31

Greets

Edit: If you're wondering why that'd even matter to me, I recently joined up with a Discord Server called "Wc3 Unforged" and most people on there run predominantly 1.27b. So, on the off-chance they might check your Campaign (I mentioned it not too long ago), I wouldn't like them to be confused and accidently download a version unfit for their prefered Wc3 version ^^''

Must say however, that if the most current version actually runs on 1.26-1.31 +reforged, it is kinda redundant to keep the 1.26-1.28 release around. If there just happen to be "edition" differences, they are not outlined anywhere, at least nowhere I could find :/
User avatar
RazorclawX
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 2026
Joined: Thu Aug 24, 2006 7:19 pm

Re: WoS Versions

Post by RazorclawX »

The campaign is edited using the 1.26a editor, that's why.
Image
-- Razorclaw X
Creator of Wanderers of Sorceria and Vision of the Future
Stalkslayer
Terran Academy Student (50k mineral debt)
Terran Academy Student (50k mineral debt)
Posts: 6
Joined: Thu Jan 30, 2020 8:23 am

Re: WoS Versions

Post by Stalkslayer »

Wow.

Let me just say that you're the most legendary coder who ever laid hands on this map editor x.x

Really wish other mapcreators would've followed your lead. We wouldn't have these compatibility issues all over the place.

Greets
User avatar
RazorclawX
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 2026
Joined: Thu Aug 24, 2006 7:19 pm

Re: WoS Versions

Post by RazorclawX »

I'm just taking advantage of the fact that Blizzard had to ensure backward compatibility to that patch at the very least is all. It does come with some down sides (such as not being able to use the newer JASS functions, but half of them don't work consistently between patches, either), but I picked this early on because I most familiar with that patch.

I don't doubt that I'll make a version that requires Reforged someday, but that ball is mostly in Blizzard's court right now (since you can't actually play Custom Campaigns in the current patch; you can at most look at it in the editor)
Image
-- Razorclaw X
Creator of Wanderers of Sorceria and Vision of the Future
Post Reply