My models do not rock, nor roll.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 8:20 am

I'm back! With bigger and better problems! Yay!

I'm trying to attach a model to a unit. I've got the basics covered, created actors for the models and units and such, and they're all attached. Yay. Here's the problem:

Unlike ground units and structures, air ships rock around, float up and down and so on. The attached models don't follow the units as they move. Not with the standard attach process.

This confounds me because the same process applied to, say, a zealot - who's model can't sit still without swaying - turns out fine. But heaven forbid the same approach work for a Battlecruiser.

SOpAttachInsertVariableHere doesn't work. None of them do. It fixes the model to the unit, but that's it.

Any ideas?

User avatar

IskatuMesk
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8783
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘
Contact:
Status: Offline

Re: My models do not rock, nor roll.

Postby IskatuMesk » Wed Oct 17, 2012 9:39 am

I have not worked with attachments in sc2 but, presuming the model is indeed being successfully attached to the bone, this hints that the bone does not animate. What bone are you trying to attach to?
Image~[Gameproc]~Image
Warning: dialogue contains politically incorrect content. Viewer rearsore may occur.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 9:48 am

From my limited knowledge of the editor thus far, it looks like there aren't that many bones to attach to. Center, Top, Weapon and Head are the specific ones I can find. And then there's a specified "Battlecruiser" attachment, but neither of these works.

Which is weird, because the ship is totally animating. I'm going to try the Uberlisk approach and see if that helps any, since it rocks and sways as it walks.

User avatar

IskatuMesk
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8783
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘
Contact:
Status: Offline

Re: My models do not rock, nor roll.

Postby IskatuMesk » Wed Oct 17, 2012 9:52 am

In most models the center, origin, and other generic attachments normally won't move (Head should move, but I can see why it doesn't on the BC). Weapon attachments are kind of weird in sc2, I had a troublesome time getting weapons to point to specific attachments back in beta/release.

It's very probable that blizzard was just very lazy with weighting on the BC.

Have you tried attaching to the Target attachments?
Image~[Gameproc]~Image
Warning: dialogue contains politically incorrect content. Viewer rearsore may occur.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 9:56 am

Yeah Target attachments seem to be the secret garden here. Secret because I have no idea which Target to anchor. The Uberlisk tut says to go with Targets 7 and 8 with different actors respectively. Those numbers seem pretty random to my pee-brain.

User avatar

IskatuMesk
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8783
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘
Contact:
Status: Offline

Re: My models do not rock, nor roll.

Postby IskatuMesk » Wed Oct 17, 2012 9:57 am

Targets will be different for each model, as I'm pretty sure they are normally used for incoming projectiles to hit the visual surface. I would say check the model previewer and look for the target bones manually, but seeing as they changed the previewer and it's much more irritating to use now, I'm not sure if a similar function is still available.
Image~[Gameproc]~Image
Warning: dialogue contains politically incorrect content. Viewer rearsore may occur.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 10:21 am

OK I see that the unit has 33 bones. So does that mean it has 33 Targets and each numbered target corresponds to the numbered bone?

For instance, 19: Ref_Engine Left = Target 19?

User avatar

IskatuMesk
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8783
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘
Contact:
Status: Offline

Re: My models do not rock, nor roll.

Postby IskatuMesk » Wed Oct 17, 2012 10:22 am

Targets are specifically named.

At least, I think they are. Let me check.

/edit

Yeah, the battlecruiser has 7 target points. Ref_Target, and then Ref_Target 01 to Ref_Target 06.
Image~[Gameproc]~Image
Warning: dialogue contains politically incorrect content. Viewer rearsore may occur.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 10:41 am

What are you looking at? I'm in the model data and where I see Targets mentioned is in Attachment Points and Bones.

I don't see anything in Attachment points for Targets 1-7

And Targets are mentioned in Bones at "17: Ref_Target" but I don't see anything to select.

I should probably mention that I am working on the Hurricane model, not the traditional Battlecruiser model, but one would think they use the same or similar data. Unless the Hurricane model has no data. Which would devastate me. For at least a few minutes.

User avatar

IskatuMesk
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8783
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘
Contact:
Status: Offline

Re: My models do not rock, nor roll.

Postby IskatuMesk » Wed Oct 17, 2012 10:47 am

I'm looking at the actual model in their "cinematics" (lol) editor, the thing that replaced the model previewer.

When inside this viewer, you need to turn on attachment viewing (Render > Show Geometry > Attachments), and then press Shift+D for the model data viewer. Then the attachment points shows everything.

Image

What was the Hurricane? Was that one of the unused models? I wouldn't be surprised if it lacks those points.
Image~[Gameproc]~Image
Warning: dialogue contains politically incorrect content. Viewer rearsore may occur.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 11:18 am

Yeah it's an unused unit. But they went out of their way to animate it, which makes me wonder if all the data isn't there anyway.

I'll check in a little bit.

User avatar

IskatuMesk
Xel'naga World Shaper
Xel'naga World Shaper
Posts: 8783
Joined: Sat Feb 07, 2009 1:40 pm
Location: M͈̙̞͍͞ͅE̹H̨͇̰͈͕͇̫Ì̩̳CO̼̩̤͖͘
Contact:
Status: Offline

Re: My models do not rock, nor roll.

Postby IskatuMesk » Wed Oct 17, 2012 12:09 pm

Blizzard is extremely heavy on copy pasta, so "animating" their battlecruisers is generally as simple as pressing keyframe and sliding something then weighting every future air unit to that bone.
Image~[Gameproc]~Image
Warning: dialogue contains politically incorrect content. Viewer rearsore may occur.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 12:44 pm

Right, so you'd think they'd just do the same with the rest of it.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 12:46 pm

Oh, looks like there's 9 target bones in this one. So they did more work on something they'd never use. Go Blizzard.


Topic author
Archangel
Terran Nuclear Silo Safety Inspector
Terran Nuclear Silo Safety Inspector
Posts: 239
Joined: Sun Jun 14, 2009 8:01 pm
Status: Offline

Re: My models do not rock, nor roll.

Postby Archangel » Wed Oct 17, 2012 2:23 pm

OK Nevermind. They didn't put the Target bones on the Hurricane.

So I made an actor with the Hurricane model and removed its animation events, then I layered it on top of a duplicated battlecruiser unit, anchored to one of its targets. Huzzah.


Return to “The Workshop”

Who is online

Users browsing this forum: No registered users and 2 guests