Page 1 of 1

[Loli] Developer log #2 11/12/2007

Posted: Tue Dec 11, 2007 8:47 pm
by IskatuMesk
So, today I went off in my mission to create a 250x250 map. The Blood Furnace.

I terrained about 1/6 of the level.

Then I tried to put it into the game.

The infamous DRLG error related to stairs error comes up and I've spent about 5 hours trying to solve it. In a bit to backdoor it, I installed the 1.10 levels.txt expansion dll plugins and added an entirely new row, set it up, ect. And now I get an access violation before the game can even try to load.

So now I can't even run the game and I must wait for feedback on the PK forums to continue. I'll remind you that a similar issue lasted for 2 months before I gave up when I was working on KTD's first prototype.

Some screenshots of the level -

Image
Image
Image
Image

Of course this was only slapped together in a few hours. It'll be more detailed as I work on it further. Ingame shots will have to wait until I can fix the crashes.

Re: [Loli] Developer log #2 11/12/2007

Posted: Tue Dec 11, 2007 9:49 pm
by UntamedLoli
I'm guessing those pink lines are the patrol pathing, also

FUCK IMAGE SCROLLING

Re: [Loli] Developer log #2 11/12/2007

Posted: Tue Dec 11, 2007 9:57 pm
by IskatuMesk
ya teh patrol lines are the pink

also lol @ scrolling

blame cc not me T.T

Re: [Loli] Developer log #2 11/12/2007

Posted: Wed Dec 12, 2007 1:17 am
by IskatuMesk
Update!

I have fixed the crash. Lesson learned - if you are going to add levels, add them entirely new and don't try to jerry rig stuff, even if you know you'll never use it.

The lvlprest stuff I was jacking for my level turned out to be responsible for the nonstop crash and only out of sheer randomness did I use a full revert on them and it started working again.

I also learned that the patrol path does not seem to work for monsters. Either that or their AI protocols that tell them to wander doesn't work, or it doesn't load them from far enough away for it to matter. They didn't patrol anywhere. How gay.